[VOTE] 4.1.M1 release

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[VOTE] 4.1.M1 release

Nikita Timofeev
Hi all,

It's release time again.
Here is 4.1.M1 version with Java 8, field-based data objects and
dep-free cayenne-server.
Please evaluate it and cast your votes.

Maven repo: https://repository.apache.org/content/repositories/orgapachecayenne-1017
Assemblies: https://dist.apache.org/repos/dist/dev/cayenne/4.1.M1/

--
Best regards,
Nikita Timofeev
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] 4.1.M1 release

Andrus Adamchik
4.1 is also affected by CAY-2366. Also found another really minor issue - https://issues.apache.org/jira/browse/CAY-2367

Running LinkRest under Cayenne 4.1 was a fun exercise. The upgrade was mostly smooth and also uncovered a few LinkRest issues with lax type conversions between JSON and DataObjects.

The only thing that was kind of confusing is that without XML files upgrade (something I forgot to do initially), the stack was able to start successfully and with no warnings [1], but no DataMaps got loaded. Perhaps we can print a warning on startup for older XML versions? Otherwise it wasn't clear what went wrong.

Andrus

[1] INFO XMLDataChannelDescriptorLoader - Loading XML configuration resource from file:/Users/andrus/work/link-rest/link-rest/link-rest/target/test-classes/cayenne-linkrest-tests.xml

> On Sep 22, 2017, at 4:45 PM, Nikita Timofeev <[hidden email]> wrote:
>
> Hi all,
>
> It's release time again.
> Here is 4.1.M1 version with Java 8, field-based data objects and
> dep-free cayenne-server.
> Please evaluate it and cast your votes.
>
> Maven repo: https://repository.apache.org/content/repositories/orgapachecayenne-1017
> Assemblies: https://dist.apache.org/repos/dist/dev/cayenne/4.1.M1/
>
> --
> Best regards,
> Nikita Timofeev

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] 4.1.M1 release

John Huss
Yeah I had that same problem. Very confusing.
On Sat, Sep 23, 2017 at 10:22 AM Andrus Adamchik <[hidden email]>
wrote:

> 4.1 is also affected by CAY-2366. Also found another really minor issue -
> https://issues.apache.org/jira/browse/CAY-2367
>
> Running LinkRest under Cayenne 4.1 was a fun exercise. The upgrade was
> mostly smooth and also uncovered a few LinkRest issues with lax type
> conversions between JSON and DataObjects.
>
> The only thing that was kind of confusing is that without XML files
> upgrade (something I forgot to do initially), the stack was able to start
> successfully and with no warnings [1], but no DataMaps got loaded. Perhaps
> we can print a warning on startup for older XML versions? Otherwise it
> wasn't clear what went wrong.
>
> Andrus
>
> [1] INFO XMLDataChannelDescriptorLoader - Loading XML configuration
> resource from
> file:/Users/andrus/work/link-rest/link-rest/link-rest/target/test-classes/cayenne-linkrest-tests.xml
>
> > On Sep 22, 2017, at 4:45 PM, Nikita Timofeev <[hidden email]>
> wrote:
> >
> > Hi all,
> >
> > It's release time again.
> > Here is 4.1.M1 version with Java 8, field-based data objects and
> > dep-free cayenne-server.
> > Please evaluate it and cast your votes.
> >
> > Maven repo:
> https://repository.apache.org/content/repositories/orgapachecayenne-1017
> > Assemblies: https://dist.apache.org/repos/dist/dev/cayenne/4.1.M1/
> >
> > --
> > Best regards,
> > Nikita Timofeev
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] 4.1.M1 release

Michael Gentry
I'm assuming due to CAY-2366 we are going to cancel the vote, fix the
issue, and re-release the artifacts?

Thanks,

mrg


On Sat, Sep 23, 2017 at 1:33 PM, John Huss <[hidden email]> wrote:

> Yeah I had that same problem. Very confusing.
> On Sat, Sep 23, 2017 at 10:22 AM Andrus Adamchik <[hidden email]>
> wrote:
>
> > 4.1 is also affected by CAY-2366. Also found another really minor issue -
> > https://issues.apache.org/jira/browse/CAY-2367
> >
> > Running LinkRest under Cayenne 4.1 was a fun exercise. The upgrade was
> > mostly smooth and also uncovered a few LinkRest issues with lax type
> > conversions between JSON and DataObjects.
> >
> > The only thing that was kind of confusing is that without XML files
> > upgrade (something I forgot to do initially), the stack was able to start
> > successfully and with no warnings [1], but no DataMaps got loaded.
> Perhaps
> > we can print a warning on startup for older XML versions? Otherwise it
> > wasn't clear what went wrong.
> >
> > Andrus
> >
> > [1] INFO XMLDataChannelDescriptorLoader - Loading XML configuration
> > resource from
> > file:/Users/andrus/work/link-rest/link-rest/link-rest/
> target/test-classes/cayenne-linkrest-tests.xml
> >
> > > On Sep 22, 2017, at 4:45 PM, Nikita Timofeev <
> [hidden email]>
> > wrote:
> > >
> > > Hi all,
> > >
> > > It's release time again.
> > > Here is 4.1.M1 version with Java 8, field-based data objects and
> > > dep-free cayenne-server.
> > > Please evaluate it and cast your votes.
> > >
> > > Maven repo:
> > https://repository.apache.org/content/repositories/orgapachecayenne-1017
> > > Assemblies: https://dist.apache.org/repos/dist/dev/cayenne/4.1.M1/
> > >
> > > --
> > > Best regards,
> > > Nikita Timofeev
> >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] 4.1.M1 release

Nikita Timofeev
Yes, let's stop voting. Fix for CAY-2366 is ready for 4.0 and should
be just ported to 4.1 branch,
fix for project version validation is on it's way.

ServerRuntime creation should fail with a meaningful message if
project file has incompatible version.

On Sun, Sep 24, 2017 at 6:16 PM, Michael Gentry <[hidden email]> wrote:

> I'm assuming due to CAY-2366 we are going to cancel the vote, fix the
> issue, and re-release the artifacts?
>
> Thanks,
>
> mrg
>
>
> On Sat, Sep 23, 2017 at 1:33 PM, John Huss <[hidden email]> wrote:
>
>> Yeah I had that same problem. Very confusing.
>> On Sat, Sep 23, 2017 at 10:22 AM Andrus Adamchik <[hidden email]>
>> wrote:
>>
>> > 4.1 is also affected by CAY-2366. Also found another really minor issue -
>> > https://issues.apache.org/jira/browse/CAY-2367
>> >
>> > Running LinkRest under Cayenne 4.1 was a fun exercise. The upgrade was
>> > mostly smooth and also uncovered a few LinkRest issues with lax type
>> > conversions between JSON and DataObjects.
>> >
>> > The only thing that was kind of confusing is that without XML files
>> > upgrade (something I forgot to do initially), the stack was able to start
>> > successfully and with no warnings [1], but no DataMaps got loaded.
>> Perhaps
>> > we can print a warning on startup for older XML versions? Otherwise it
>> > wasn't clear what went wrong.
>> >
>> > Andrus
>> >
>> > [1] INFO XMLDataChannelDescriptorLoader - Loading XML configuration
>> > resource from
>> > file:/Users/andrus/work/link-rest/link-rest/link-rest/
>> target/test-classes/cayenne-linkrest-tests.xml
>> >
>> > > On Sep 22, 2017, at 4:45 PM, Nikita Timofeev <
>> [hidden email]>
>> > wrote:
>> > >
>> > > Hi all,
>> > >
>> > > It's release time again.
>> > > Here is 4.1.M1 version with Java 8, field-based data objects and
>> > > dep-free cayenne-server.
>> > > Please evaluate it and cast your votes.
>> > >
>> > > Maven repo:
>> > https://repository.apache.org/content/repositories/orgapachecayenne-1017
>> > > Assemblies: https://dist.apache.org/repos/dist/dev/cayenne/4.1.M1/
>> > >
>> > > --
>> > > Best regards,
>> > > Nikita Timofeev
>> >
>> >
>>



--
Best regards,
Nikita Timofeev