Re-engineering DB fails to load stored procedures 4.0M3

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re-engineering DB fails to load stored procedures 4.0M3

Fredrik Widengren
Hello,

I'm trying to re-engineer a db with the modeller. I'm using 4.0M3. I have
had issues with it before but have usually been successful at last, but now
I just can't get it right. It works fine with the 4.0 beta release, but I'm
using the legacy naming class since before. That one is not available in
4.0 beta, so I can't use that that release unfortunately (without a lot of
additional work).
Now I need to re-engineer again due to that I have made changes to the DB
via sql. But the stored procedures are not being loaded.

Any ideas what I might be doing wrong?

Thanks,
/Fredrik
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Re-engineering DB fails to load stored procedures 4.0M3

Nikita Timofeev
Hi Fredrik,

You are doing nothing wrong, import of stored procedures was
completely broken in 4.0.M3 [1], you can either use M4 or later if you
can, or manually create required procedures.

[1] https://issues.apache.org/jira/browse/CAY-2128

On Fri, Jul 28, 2017 at 7:38 PM, Fredrik Widengren
<[hidden email]> wrote:

> Hello,
>
> I'm trying to re-engineer a db with the modeller. I'm using 4.0M3. I have
> had issues with it before but have usually been successful at last, but now
> I just can't get it right. It works fine with the 4.0 beta release, but I'm
> using the legacy naming class since before. That one is not available in
> 4.0 beta, so I can't use that that release unfortunately (without a lot of
> additional work).
> Now I need to re-engineer again due to that I have made changes to the DB
> via sql. But the stored procedures are not being loaded.
>
> Any ideas what I might be doing wrong?
>
> Thanks,
> /Fredrik



--
Best regards,
Nikita Timofeev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Re-engineering DB fails to load stored procedures 4.0M3

Fredrik Widengren
Hello Nikita
Many thanks for the feedback! Then I know how to proceed.
/Fredrik

Skickat från min iPhone

> 1 aug. 2017 kl. 09:26 skrev Nikita Timofeev <[hidden email]>:
>
> Hi Fredrik,
>
> You are doing nothing wrong, import of stored procedures was
> completely broken in 4.0.M3 [1], you can either use M4 or later if you
> can, or manually create required procedures.
>
> [1] https://issues.apache.org/jira/browse/CAY-2128
>
> On Fri, Jul 28, 2017 at 7:38 PM, Fredrik Widengren
> <[hidden email]> wrote:
>> Hello,
>>
>> I'm trying to re-engineer a db with the modeller. I'm using 4.0M3. I have
>> had issues with it before but have usually been successful at last, but now
>> I just can't get it right. It works fine with the 4.0 beta release, but I'm
>> using the legacy naming class since before. That one is not available in
>> 4.0 beta, so I can't use that that release unfortunately (without a lot of
>> additional work).
>> Now I need to re-engineer again due to that I have made changes to the DB
>> via sql. But the stored procedures are not being loaded.
>>
>> Any ideas what I might be doing wrong?
>>
>> Thanks,
>> /Fredrik
>
>
>
> --
> Best regards,
> Nikita Timofeev
Loading...